EmuCR Feeds
Email Us

EmuCR: DolphinDolphin v5.0 is released. Dolphin is the first Gamecube emulator able to run commercial games! Dolphin is a Gamecube, Wii and Triforce (the arcade machine based on the Gamecube) emulator which supports many extra features and abilities not present on the original consoles. It has a partial Wii support and plays most Gamecube games.

Dolphin v5.0 changelog:
* 64-bit CPUs and Operating Systems are required.
* Windows XP is no longer supported. Windows Vista is no longer officially supported.
* Direct3D10/OpenGL3 Required. This means AMD Radeon 4xxx, NVIDIA GeForce 8xxx, or Intel HD 2xxx minimum! Anything older than that will most likely not work or will have significant glitches.

Download: Dolphin v5.0
Source: Here

Random Related Topic Refresh Related Topic

Random Related Topic Loading...

6 Comments:

  1. Agradecimentos eternos a todos,lembro sempre quando abro o dolphin que um dos mesbros cometeu suicidio. Que sua veja este momento impar do emulador. Obrigado

    ReplyDelete
  2. Don't get it here, get it on the official Dolphin site, less adware.

    ReplyDelete
  3. excelnte thx Dolphin TEAM. :D

    ReplyDelete
  4. >64 bit CPUs are required
    The hell does that mean? They should've said "x86-64 architecture CPUs", not just "64 bit", because now this creates a possibility for confusion by some of the users, since there are processors out there that are strictly 64 bit, and if you say it the way they did then you're automatically assuming they're talking about 64 bit-only CPUs. I swear to god, Dolphin team is so friggin' immature when it comes down to writing change logs, sheesh...

    ReplyDelete
  5. Full change log are here!

    https://dolphin-emu.org/blog/2016/06/24/dolphin-50-release/#cuthere

    Look likes this emulator requires NEWEST SPECS likes I7, 5 cores etc...

    ReplyDelete
    Replies
    1. Runs perfectly fine on my i7 2600K, which is almost six years old by now. I'm using it in the combination with a PowerColor's Radeon R9 270X Devil video card, BTW. Everything works absolutely fine. In addition to what I've already said previously, I should also point out the very obvious illogical misleading flaw in that change log's text regarding the Windows Vista. They say that Dolphin 5.0 doesn't officially support Vista from now on, yet it runs perfectly fine on my Windows 7 Ultimate x64 bit SP1, and Windows 7 was based on Windows Vista. Absolutely illogical to proclaim that "Vista is not officially supported anymore" when it runs perfectly fine on Windows 7 which is essentially a variant of Vista too.

      Delete

Can't post a comment? Try This!