EmuCR Feeds
Email Us

EmuCR: yuzuyuzu Git (2018/07/20) is complied. yuzu is a work-in-progress Nintendo Switch emulator. yuzu is an open-source project, licensed under the GPLv2 (or any later version). yuzu has been designed with portability in mind, with builds available for Windows, Linux, and macOS. The project was started in spring of 2017 by bunnei, one of the original authors of the popular Citra 3DS emulator, to experiment with and research the Nintendo Switch. Due to the similarities between Switch and 3DS, yuzu was developed as a fork of Citra. This means that it uses the same project architecture, and both emulators benefit from shared improvements. During the early months of development, work was done in private, and progress was slow. However, as Switch reverse-engineering and homebrew development became popular, work on yuzu began to take off as well.

yuzu Git Changelog:
* Merge pull request #730 from lioncash/string
* gl_shader_decompiler: Remove unnecessary const from return values
* Merge pull request #729 from lioncash/simplify
* pl_u: Simplify WriteBuffer() calls in GetSharedFontInOrderOfPriority()
* Merge pull request #726 from lioncash/overload
* hle_ipc: Introduce generic WriteBuffer overload for multiple container types
* Merge pull request #725 from lioncash/bytes
* pl_u: Specify correct size for buffers in GetSharedFontInOrderOfPriority()
* Merge pull request #728 from Subv/acc_profile
* HLE/ACC: Return an IProfile that is consistent with what was requested.
* HLE/ACC: Change the default user id to be consistent with what we tell games on startup.
* Merge pull request #727 from Subv/acc_users
* HLE/ACC: Write a single whole user id in ListAllUsers and ListOpenUsers.
* Merge pull request #724 from lioncash/printf
* pl_u: Remove printf specifier in log call in a log call in GetSharedFontInOrderOfPriority()
* Merge pull request #723 from lioncash/gdb
* gdbstub: Get rid of a few signed/unsigned comparisons
* Merge pull request #722 from lioncash/signed
* hid: Use a ranged-for loops in UpdatePadCallback
* hid: Use HID_NUM_LAYOUTS constant for indicating size of the layouts array
* Merge pull request #721 from lioncash/svc
* svc: Correct always true assertion case in SetThreadCoreMask
* Merge pull request #719 from lioncash/docs
* loader: Amend Doxygen comments
* Merge pull request #718 from lioncash/read
* loader/nso: Check if read succeeded in IdentifyFile() before checking magic value
* Merge pull request #717 from lioncash/explicit
* hle/service: Make constructors explicit where applicable
* Merge pull request #716 from lioncash/construct
* nvflinger: Emplace Display instances directly
* Merge pull request #715 from lioncash/const-ref
* nvdrv: Take std::string by const reference in GetDevice()
* Merge pull request #720 from Subv/getentrytype_root
* Filesystem: Return EntryType::Directory for the root directory.
* Merge pull request #714 from lioncash/index
* hle_ipc: Amend usage of buffer_index within one of HLERequestContext's WriteBuffer() overloads
* Merge pull request #712 from lioncash/fsp
* fsp_srv: Remove unnecessary vector construction in IFile's Write() function
* fsp_srv: Remove unnecessary std::vector construction in IDirectory's Read() function
* fsp_srv: Make IStorage constructor explicit
* fsp_srv: Add missing includes
* fsp_srv: Resolve sign-mismatch warnings in assertion comparisons
* fsp_srv: Respect write length in Write()
* Merge pull request #713 from lioncash/filesys
* filesystem: std::move VirtualDir instance in VfsDirectoryServiceWrapper's constructor
* filesystem: Use std::string's empty() function instead of comparing against a literal
* filesystem: Remove pragma disabling global optimizations
* Merge pull request #711 from lioncash/swap
* common/swap: Remove unnecessary const on return value of swap()
* common/swap: Use static_cast where applicable
* common/swap: Use using aliases where applicable
* Merge pull request #710 from lioncash/unused
* common/common_funcs: Remove unused rotation functions
* Merge pull request #694 from lioncash/warn
* loader/nro: Resolve sign mismatch warnings
* loader/nso: Remove unnecessary vector resizes
* loader/nso: Resolve sign mismatch warnings
* Merge pull request #709 from lioncash/thread-local
* common/misc: Deduplicate code in GetLastErrorMsg()
* Merge pull request #708 from lioncash/xbyak
* externals: Update Xbyak to 5.65
* Merge pull request #707 from lioncash/catch
* externals: Update catch to v2.2.3
* Merge pull request #705 from lioncash/string-ref
* file_util: return string by const reference for GetExeDirectory()
* Merge pull request #704 from lioncash/string
* string_util: Remove AsciiToHex()
* Merge pull request #703 from lioncash/const
* savedata_factory: Make SaveDataDescriptor's DebugInfo() function a const member function
* Merge pull request #702 from lioncash/initialize
* partition_filesystem: Ensure all class members of PartitionFilesystem are initialized
* Merge pull request #701 from lioncash/moving
* content_archive: Make IsDirectoryExeFS() take a shared_ptr as a const reference
* content_archive: Add missing standard includes
* content_archive: std::move VirtualFile in NCA's constructor
* Merge pull request #699 from lioncash/vfs
* vfs: Deduplicate accumulation code in VfsDirectory's GetSize()
* Merge pull request #697 from bunnei/disable-depth-cull
* gl_state: Temporarily disable culling and depth test.

Download: yuzu Git (2018/07/20)
Source:Here

Random Related Topic Refresh Related Topic

Random Related Topic Loading...

0 Comments

Post a Comment

Can't post a comment? Try This!