EmuCR Feeds
Email Us

EmuCR: yuzuyuzu Git (2019/04/06) is complied. yuzu is a work-in-progress Nintendo Switch emulator. yuzu is an open-source project, licensed under the GPLv2 (or any later version). yuzu has been designed with portability in mind, with builds available for Windows, Linux, and macOS. The project was started in spring of 2017 by bunnei, one of the original authors of the popular Citra 3DS emulator, to experiment with and research the Nintendo Switch. Due to the similarities between Switch and 3DS, yuzu was developed as a fork of Citra. This means that it uses the same project architecture, and both emulators benefit from sharead improvements. During the early months of development, work was done in private, and progress was slow. However, as Switch reverse-engineering and homebrew development became popular, work on yuzu began to take off as well.

yuzu Git Changelog:
* Merge pull request #2317 from FernandoS27/sync
* Implement SyncPoint Register in the GPU.
* Merge pull request #2325 from lioncash/name
* kernel/server_session: Provide a GetName() override
* Merge pull request #2342 from lioncash/warning
* common/multi_level_queue: Silence truncation warning in iterator operator++
* common/bit_util: Make CountLeading/CountTrailing functions have the same return types
* Merge pull request #2240 from FearlessTobi/port-4651
* gdbstub: Fix some bugs in IsMemoryBreak() and ServeBreak. Add workaround to let watchpoints break into GDB. (#4651)
* Merge pull request #2346 from lioncash/header
* video_core/engines: Make memory manager members private
* video_core/engines: Remove unnecessary inclusions where applicable
* Merge pull request #2350 from lioncash/vmem
* video_core/memory_manager: Make Read() a const qualified member function
* video_core/memory_manager: Make ReadBlock() a const qualifier member function
* video_core/memory_manager: Add a const qualified variant of GetPointer()
* video_core/memory_manager: Make FindFreeRegion() a const member function
* video_core/memory_manager: Make GpuToCpuAddress() a const member function
* Merge pull request #2340 from lioncash/view
* file_sys/fsmitm_romfsbuild: Utilize a string_view in romfs_calc_path_hash()
* Merge pull request #2334 from lioncash/override
* core: Add missing override specifiers where applicable
* Merge pull request #2347 from lioncash/trunc
* video_core/gpu_thread: Silence truncation warning in ThreadManager's constructor
* Merge pull request #2341 from lioncash/compare
* file_sys/nca_metadata: Remove unnecessary comparison operators for TitleType
* Merge pull request #2339 from lioncash/rank
* service/fsp_srv: Don't pass SaveDataDescriptor instances by value.
* service/fsp_srv: Remove unnecessary unknown member in OpenSaveDataFileSystem
* service/fsp_srv: Update SaveDataInfo and SaveDataDescriptor structs
* Merge pull request #2327 from ReinUsesLisp/crash-safe-visit
* gl_shader_decompiler: Return early when an operation is invalid
* Merge pull request #2343 from lioncash/todo
* file_sys/program_metadata: Remove obsolete TODOs
* Merge pull request #2337 from lioncash/temporary
* gl_shader_decompiler: Rename GenerateTemporal() to GenerateTemporary()
* Merge pull request #2329 from lioncash/sanitize
* kernel/svc: Properly sanitize mutex address in WaitProcessWideKeyAtomic
* Merge pull request #2344 from lioncash/result
* hle/result: Remove unnecessary bitfield entry for ResultCode
* Merge pull request #2349 from lioncash/surface
* yuzu/debugger/graphics_surface: Display error messages for file I/O errors
* yuzu/debugger/graphics_surface: Tidy up SaveSurface
* yuzu/debugger/graphics_surface: Clean up connection overload deduction
* yuzu/debugger/graphics_surface: Fill in missing surface format listings
* Merge pull request #2351 from lioncash/macro
* video_core/macro_interpreter: Remove assertion within FetchParameter()
* video_core/macro_interpreter: Simplify GetRegister()
* Merge pull request #2338 from lioncash/fs
* filesystem: Use a std::string_view in OpenFile()
* Merge pull request #2282 from bunnei/gpu-asynch-v2
* gpu_thread: Improve synchronization by using CoreTiming.
* Merge pull request #2292 from lioncash/nacp
* file_sys/control_metadata: Amend naming of members
* Merge pull request #2335 from lioncash/service-unused
* hle/service: Resolve unused variable warnings
* Merge pull request #2336 from ReinUsesLisp/txq
* gl_shader_decompiler: Fix TXQ types
* Merge pull request #2331 from lioncash/cache
* yuzu/main: Use QStringLiteral where applicable within OnTransferableShaderCacheOpenFile()
* yuzu/main: Tidy up the error dialog string in OnTransferableShaderCacheOpenFile()
* yuzu/main: Remove unnecessary string concatenation in OnTransferableShaderCacheOpenFile()
* yuzu/main: Make open_target a QString
* yuzu/main: Use static variant of QFile's exists()
* Merge pull request #2333 from lioncash/video-include
* video_core/renderer_opengl: Remove unnecessary includes
* Merge pull request #2332 from lioncash/include
* yuzu/main: Remove unnecessary includes
* Merge pull request #2330 from lioncash/pragma
* common/lz4_compression: Remove #pragma once directive from the cpp file
* Merge pull request #2328 from lioncash/transfer
* service/am: Correct behavior of CreateTransferMemoryStorage()
* kernel/transfer_memory: Add accessors to data and sizes
* Merge pull request #2095 from FreddyFunk/open-transferable-shader-cache
* Use QString instead of std::string where applicable
* Use constexpr char array instead of string where applicable
* frontend: Open transferable shader cache for a selected game in the gamelist
* Merge pull request #2093 from FreddyFunk/disk-cache-better-compression
* gl_shader_disk_cache: Use LZ4HC with compression level 9 instead of compression level 12 for less compression time
* Addressed feedback
* core: Do not link LZ4 to core. Use common/data_compression for nso segment decompression instead.
* gl_shader_disk_cache: Use better compression for transferable and precompiled shader disk chache files
* data_compression: Move LZ4 compression from video_core/gl_shader_disk_cache to common/data_compression
* Merge pull request #2299 from lioncash/maxwell
* gl_shader_manager: Remove unnecessary gl_shader_manager inclusion
* gl_shader_manager: Move using statement into the cpp file
* gl_shader_manager: Remove reliance on global accessor within MaxwellUniformData::SetFromRegs()
* gl_shader_manager: Amend Doxygen string for MaxwellUniformData
* Merge pull request #2324 from lioncash/enum-unused
* kernel/object: Remove unused handle type entry
* Merge pull request #2294 from lioncash/fatal
* service/am: Implement EnterFatalSection and LeaveFatalSection
* service/am: Sort ISelfController's member functions according to table order
* Merge pull request #2323 from lioncash/include
* yuzu/debugger/profiler: Remove unnecessary includes
* Merge pull request #2302 from ReinUsesLisp/vk-swapchain
* vk_swapchain: Implement a swapchain manager
* Merge pull request #2305 from lioncash/shared
* kernel/shared_memory: Remove unused core/memory.h include
* kernel/shared_memory: Sanitize supplied size when unmapping
* Merge pull request #2314 from lioncash/const
* kernel/thread: Make AllWaitObjectsReady() a const qualified member function
* kernel/wait_object: Make ShouldWait() take thread members by pointer-to-const
* kernel/thread: Avoid sign conversion within GetCommandBufferAddress()
* kernel/thread: Make parameter of GetWaitObjectIndex() const qualified
* Merge pull request #2326 from lioncash/translation
* yuzu/applets/software_keyboard: Use QDialogButtonBox standard buttons instead of custom buttons
* yuzu/applets/profile_select: Use QDialogButtonBox standard buttons instead of custom buttons

Download: yuzu Git (2019/04/06)
Source:Here



Random Related Topic Refresh Related Topic

Random Related Topic Loading...

0 Comments

Post a Comment

Can't post a comment? Try This!