EmuCR Feeds
Email Us

EmuCR: DolphinDolphin Git 5.0-4072 is compiled. This is the trunk of Dolphin Project. Dolphin is the first Gamecube emulator able to run commercial games! Dolphin is a Gamecube, Wii and Triforce (the arcade machine based on the Gamecube) emulator which supports many extra features and abilities not present on the original consoles. It has a partial Wii support and plays most Gamecube games.

Dolphin Git changelog:
* Merge pull request #5532 from JosJuice/dont-show-fst-size
Don't show FST size in game properties
* Don't show FST size in game properties
Normal users don't care about it. In fact, people care so
little about it that the Wii implementation of it was broken
starting from when it was implemented (eb65601) to 7 years
later (e0a47c1), apparently without anyone reporting it.
* Merge pull request #5434 from TaoSc/master
Update libpng to 1.6.29
* Update libpng to 1.6.29
* Merge pull request #5528 from shuffle2/msvc-defalign
msvc: use 8 byte struct member alignment instead of 16
* msvc: use 8 byte struct member alignment instead of 16
* Merge pull request #5521 from JosJuice/check-has-partitions
Check for existance of partitions instead of disc type when appropriate
* FilesystemPanel: Remove strange disc type check
I don't know what the point of this was.
(Workaround for some old bug that we don't have anymore?)
* DVDInterface: Remove useless disc type check
* Check for existance of partitions instead of disc type when appropriate
This gets rid of some assumptions that non-DiscIO code was making about
volume types. It's better to encapsulate as many of the volume type
differences as possible in DiscIO.
Made possible by PR #2353.
* Merge pull request #5519 from JosJuice/titledatabase-japanese
TitleDatabase: Allow showing Japanese names for Japanese GC games
* TitleDatabase: Check game ID length before reading characters
* TitleDatabase: Allow showing Japanese names for Japanese GC games
* Merge pull request #5526 from ligfx/fixqtc++17
CMake: make Qt work when using a manual "-std=c++##" flag
* CMake: make Qt work when using a manual "-std=c++##" flag
Based on approach in https://gitlab.kitware.com/cmake/cmake/issues/16468
* Merge pull request #5522 from leoetlino/simpler-gettitleid
DiscIO: Use std::optional for GetTitleID instead of pointer
* DiscIO: Use std::optional for GetTitleID instead of pointer
This makes the interface slightly cleaner and a bit more consistent
with the other getters. Still not fully the same, since the others
don't really handle failures with std::optional; but at least the
value is returned by value now, as opposed to having the function
take a pointer to a u64.
* Merge pull request #5432 from sepalani/fd-table
IOS/Network: Emulate socket fd table
* IOS/Network: Fix some error return values
* IOS/Network: Use Wii's fd in logs rather than host's fd
* IOS/Network: Handle SO_ENETRESET
* IOS/Network: Handle SO_ENOMEM
* IOS/Network: Handle SO_EPROTOTYPE
* IOS/Network: Handle SO_EMFILE
* IOS/Network: Emulate socket fd table
* Merge pull request #5512 from shuffle2/vs-cleanup
VS cleanup
* msbuild: remove /EHa for wxw, which was just an old warning workaround
* msbuild: EnableFiberSafeOptimizations is an opt. inhibitor; disable it.
* msbuild: remove more meaningless stuff
* msbuild: wxw does not need xxhash to build
* msbuild: remove more duplicate code
* msbuild: make Externals inclusion methods uniform
* msbuild: remove extra zlib include from UICommon
* msvc: add /Zc:throwingNew
* msvc: use pretty compiler diagnostics
* msvc: bump the required _MSC_FULL_VER
* remove duplicate code in msbuild files
* clarify a little in Base.props
* cubeb: don't define _MBCS or redefine _CRT_SECURE_NO_WARNINGS
* remove unused msbuild file content
* might as well update yet some more pointless version numbers..
* wxw: clean up vcxproj a bit
* wxw[msw]: disable wxUSE_DBGHELP (issue 7591)
* DolphinQt: remove I_AM_BUILDACUS as the buildbot doesn't use it anymore
* Include utf8 BOM in sln file so shell displays a nice icon
* msbuild: increment other version numbers to vs2017 equivalents
* [windows] Do not copy cpack_package_description.txt to output dir
* remove ProjectDependencies from sln file
* Merge pull request #5513 from leoetlino/dns-timeout
Analytics: Don't crash when a DNS resolve times out
* Analytics: Don't crash when a DNS resolve times out
* Merge pull request #5525 from lioncash/overload
Device: Provide operator!= counterparts to operator== for DeviceQualifier
* Device: Provide operator!= counterparts to operator== for DeviceQualifier
Makes comparison logic symmetric
* Merge pull request #5520 from sepalani/write-console
HLE: Fix __write_console implementation
* HLE: Fix __write_console implementation
* Merge pull request #5517 from leoetlino/more-reliable-shutdown
More reliable shutdown
* WX: Clear m_is_game_loading at the proper moment
This should happen after the core has stopped (OnStopped), not when
the user wants to stop (DoStop).
* Core: Use RAII for EmuThread shutdown
This is more reliable, as this guarantees subsystems will be
shut down in the same order they were initialised (if they were
initialised). It also allows us to stop keeping track of what needs to
be shut down manually and just return in case of errors.
This should prevent the emulator from getting totally stuck when
the boot process does fail.
* Merge pull request #5516 from leoetlino/drop-last-filename
Drop m_LastFilename
* Core: Remove unneeded config save
We don't touch the user config during booting, so there is nothing to
manually save.
* Drop m_LastFilename
This makes it hard to support different boot params for different boot
types. We should not be making the assumption that Dolphin will
always be booting directly from a file (and in particular, only
using a string).
It's incompatible with future changes that will allow Dolphin to boot
a NAND title properly from well, the NAND, as opposed to booting from
WADs. (And no, treating the title TMD as a "bootable" path doesn't
count. Especially when that approach won't work with NAND images
or IOS LLE.)
And it's confusing to expose this functionality from the UI. It's
pretty bad for UX to change the play button's behaviour depending on
whether the user has launched something before, configured a default
file to boot, added a directory to their game paths.
* Merge pull request #5518 from JosJuice/replace-weird-brace-thingy
Replace {{}} with {}
* Replace {{}} with {}
IIRC we were only using {{}} because {} used to cause errors
on the FreeBSD buildbot.
* Merge pull request #5366 from sepalani/set-sym-size
CodeView: Set Symbol Size/End Address added
* CodeView: Remove accelerator duplicates
* CodeView: Set Symbol End Address added
* CodeView: Set Symbol Size added
* Merge pull request #5515 from leoetlino/import-ticket
IOS/ES: Move ImportTicket write function
* IOS/ES: Move ImportTicket write function
This commit moves the write function to where it should be (IOS),
especially when ES::ImportTicket() is the only place to use it.
Prevents misusing the ticket import function, and removes one unsafe
direct write to the NAND that does not go through IOS.
This also fixes the destination path: the session root is the one which
should be used for determining the ticket path, not the configured one.
* Merge pull request #5514 from JosJuice/updaterunninggamemetadata-optional
Use std::optional for UpdateRunningGameMetadata
* Use std::optional for UpdateRunningGameMetadata

Download: Dolphin Git 5.0-4072 x64
Download: Dolphin Git 5.0-4072 Android
Source: HereDolphin Git 5.0-2877

Random Related Topic Refresh Related Topic

Random Related Topic Loading...


Post a Comment

Can't post a comment? Try This!