EmuCR Feeds
Email Us

EmuCR: yuzuyuzu Git (2019/06/06) is complied. yuzu is a work-in-progress Nintendo Switch emulator. yuzu is an open-source project, licensed under the GPLv2 (or any later version). yuzu has been designed with portability in mind, with builds available for Windows, Linux, and macOS. The project was started in spring of 2017 by bunnei, one of the original authors of the popular Citra 3DS emulator, to experiment with and research the Nintendo Switch. Due to the similarities between Switch and 3DS, yuzu was developed as a fork of Citra. This means that it uses the same project architecture, and both emulators benefit from sharead improvements. During the early months of development, work was done in private, and progress was slow. However, as Switch reverse-engineering and homebrew development became popular, work on yuzu began to take off as well.

yuzu Git Changelog:
* Merge pull request #2520 from ReinUsesLisp/vulkan-refresh
* vk_device: Let formats array type be deduced
* vk_shader_decompiler: Misc fixes
* vk_device: Enable features when available and misc changes
* Merge pull request #2540 from ReinUsesLisp/remove-guest-position
* gl_shader_decompiler: Remove guest "position" varying
* Merge pull request #2419 from DarkLordZach/srv-lr-iface
* ncm: Implement LR OpenAddOnContentLocationResolver (2)
* ncm: Implement LR OpenRegisteredLocationResolver (1)
* ncm: Implement LR OpenLocationResolver (0)
* Merge pull request #2521 from lioncash/naming
* yuzu/configuration: Make function naming consistent
* Merge pull request #2512 from ReinUsesLisp/comp-indexing
* gl_shader_decompiler: Use an if based cbuf indexing for broken drivers
* gl_device: Add test to detect broken component indexing
* Merge pull request #2526 from lioncash/global
* core/core: Remove unnecessary includes
* yuzu_cmd/yuzu: Correct formatting specifier
* core/loader: Remove LoadKernelSystemMode
* core/telemetry_session: Remove unnecessary web service nulling out in destructor
* core/telemetry_session: Remove usages of the global system accessor
* core/telemetry_session: Explicitly delete copy and move constructors
* core/telemetry_session: Remove unused include
* Merge pull request #2545 from lioncash/timing
* core/core_timing_util: Amend casing of cyclesTo* functions
* core/core_timing_util: Use std::chrono types for specifying time units
* core/core_timing_utils: Simplify overload set
* Merge pull request #2541 from lioncash/input
* input_common/sdl/sdl_impl: Correct logging string in SDLState constructor
* input_common/sdl/sdl_impl: Move documentation comments to header where applicable
* input_common/sdl/sdl_impl: Amend names for axes for SDLAnalogPoller
* input_common/sdl/sdl_impl: Mark variables const where applicable
* input_common/sdl/sdl_impl: Mark SDLEventToButtonParamPackage() as static
* input_common/sdl/sdl_impl: Convert reinterpret_cast into a static_cast
* input_common/sdl/sdl_impl: Use insert_or_assign() where applicable
* input_common/sdl/sdl_impl: Simplify SDL_Joystick deleter handling
* input_common/sdl/sdl_impl: Resolve two sign conversion warnings
* input_common/sdl: Remove unused header includes and forward declarations
* input_common/sdl/sdl_impl: Use nested namespace specifiers where applicable
* Merge pull request #2510 from SciresM/desired_language
* Fix bitmask logic inversion
* fix introduced clang-format errors
* Address review comments
* clang-format fixes
* Implement IApplicationFunctions::GetDesiredLanguage
* Merge pull request #2527 from lioncash/index
* yuzu/software_keyboard: Remove unnecessary GetStatus() member function
* profile_select: Remove unnecessary GetStatus() member function
* profile_select: Return int instead of u32 for GetIndex()
* Merge pull request #2534 from ReinUsesLisp/shader-cleanup
* gl_shader_cache: Store a system class and drop global accessors
* gl_shader_cache: Add commentaries explaining the intention in shaders creation
* gl_shader_cache: Flip if condition in GetStageProgram to reduce indentation
* Merge pull request #2531 from ReinUsesLisp/qt-warnings
* qt: Silence name collision warnings
* Merge pull request #2515 from lioncash/narrowing
* yuzu/configuration/configure_graphics: Eliminate type narrowing in a connect call
* Merge pull request #2532 from ShalokShalom/patch-2
* Remove outdated info about compability
* Merge pull request #2536 from lioncash/cache
* game_list_worker: Use QFile over our own IOFile instance or std streams
* game_list_worker: Remove template specializations

Download: yuzu Git (2019/06/06)

Random Related Topic Refresh Related Topic

Random Related Topic Loading...


Post a Comment

Can't post a comment? Try This!